执行 composer update 命令的时候报 Your requirements could not be resolved to an installable set of packages.

PHP深入实践 专栏收录该内容
70 篇文章 0 订阅

Your requirements could not be resolved to an installable set of packages.

以上原因:不匹配composer.json要求的版本。

 

解决方案:

composer可以设置忽略版本匹配,

composer install --ignore-platform-reqs
composer update --ignore-platform-reqs

再次执行composer命令可以正常安装包了。

  • 2
    点赞
  • 1
    评论
  • 1
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

相关推荐
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值